Skip to main content

Getting started

C# is a modern, object-oriented, and type-safe programming language. C# enables developers to build many types of secure and robust applications that run in .NET.

This guide shows how to create and run a .NET console application by using Visual Studio Code and the .NET CLI (command-line interface). Project tasks, such as creating, compiling, and running a project are done by using the .NET CLI. You can follow this tutorial with a different code editor and run commands in a terminal if you prefer.

Prerequisities​

Create a console application​

Create a .NET console app project named HelloStruSoft.

  1. Start Visual Studio Code.

  2. Select File > Open Folder from the main menu.

  3. In the Open Folder dialog, create a HelloStruSoft folder and select it. Then click Select Folder

  4. The folder name becomes the project name and the namespace name by default. You'll add code later in the tutorial that assumes the project namespace is HelloStruSoft.

  5. Open the Terminal in Visual Studio Code by selecting View > Terminal from the main menu.

    The Terminal opens with the command prompt in the HelloStruSoft folder.

  6. In the Terminal, enter the following command:

    dotnet new console
    dotnet add package FemDesign.Core

    The project template creates a simple application that displays "Hello World" in the console window by calling the Console.WriteLine(String) method in Program.cs.

  7. Replace the contents of Program.cs with the following code:

    using FemDesign;

    namespace HelloStruSoft
    {
    class Program
    {
    static void Main(string[] args)
    {
    Console.WriteLine("Welcome to FEM-Design API!\n");

    var point = new FemDesign.Geometry.Point3d(0, 0, 0);
    Console.WriteLine($"You have just created a Point3d in {point.X}, {point.Y}, {point.Z}.");
    }
    }
    }

    The first time you edit a .cs file, Visual Studio Code prompts you to add the missing assets to build and debug your app. Select Yes, and Visual Studio Code creates a .vscode folder with launch.json and tasks.json files.

    info

    If you don't get the prompt, or if you accidentally dismiss it without selecting Yes, do the following steps to create launch.json and tasks.json:

    Select Run > Add Configuration from the menu. Select .NET 5+ and .NET Core at the Select environment prompt.

    The code defines a class, Program, with a single method, Main, that takes a String array as an argument. Main is the application entry point, the method that's called automatically by the runtime when it launches the application. Any command-line arguments supplied when the application is launched are available in the args array.

Run the application​

Run the following command in the Terminal:

dotnet run

The program displays

Welcome to FEM-Design API!
You have just created a Point3d in 0, 0, 0.

Congratulations, you have successfully created your first FEM-Design Application! 🎉